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===============================================================
WARNING! WARNING! WARNING! WARNING! WARNING!
WARNING! WARNING! WARNING! WARNING! WARNING!
WARNING! WARNING! WARNING! WARNING! WARNING!

THIS MUST NOT TO BE DONE ON ENGINES WITHIN THE USA!!!
 There are steep penalties for modifying the emissions 
components on any engine that falls Under EPA
Regulations. Doing so will land you with SERIOUS FINES!!
===============================================================

===============================================================
WARNING! WARNING! WARNING! WARNING! WARNING!
DO NOT USE THE BACKUP/RESTORE PARAMATERS

OPTION IN CALTERM!!!
When Downloading your Cal file to your engine, MAKE SURE THE 

OPTION TO BACKUP/RESTORE PARAMETERS IS NOT CHECKED in Calterm. 
Some of the features and parameters HAVE TO BE EDITED, and are 
part of the delete. Restoring your features using Calterm will 
overwrite them back to their original values and could make 
your Calibration unstable.
===============================================================

===============================================================
WARNING! WARNING! WARNING! WARNING! WARNING!

DO NOT REMOVE HARDWARE FROM YOUR ENGINE UNTIL YOU KNOW YOUR
DELETE IS WORKING!!!

You should ABSOLUTELY verify your 'Milk Money' delete BRFORE 
REMOVING YOUR HARDWARE OR UNPLUGGING ANYTHING!

After the Delete, start the truck and verify your VGT 
position!. Make sure it is below 30% during idle, unless you 
have specifically set it somewhere else. This is very 
important. If you have done everything right, and your VGT 
position is above 69%, then something is very wrong.



===============================================================
This document is an ongoing process, Check regularly for updates!

Mama's EGR Milk Money Step-by-Step...

This is NOT the main document!

This document is only the How-to for the MM2 delete,... Please refer to the file ' Mama's EGR Milk 
Money(2.0) explained.pdf ' if you want to understand what this delete actually does. I made this document 
separate, so that those people wanting to simply 'Get it Over With' can do so without all the bla bla bla getting 
in the way. It assumes you have Insite, Calterm, and any/all other software installed and set up on your PC like 
explained in the main MM document.

  There are some abbreviations in this file that confuse people, so just be aware of them,...

'ECM' – Engine Control Module,.. The actual 'Brain' of your truck engine. It is the computer that runs the 
engine.

'cal' or 'cal file' – This is a slang word used by ECM tuners, and has nothing to do with the states of California.
A Cal is known as a Calibration File. It is the actual operating software that runs in your ECM.

'BAC' – This is the code-lettering that the Calterm software uses for the CM871 engine. BBZ, for example is 
for the CM2250. It has nothing whatsoever to do with the word BACkup at all. Don't be confused by it.

'ecfg' – This is a file you need that tells Calterm how to properly communicate with your particular ECM. 
There are several Dozen of them for the CM871 alone. You NEED the right one that matches the cal file in your
engine. Using the wrong file will cause problems and can corrupt the ECM.

– Enough Blabbering, lets get started shall we?,...

Backing up the ECM and Documenting Everything First!...

BEFORE GOING ANY FURTHER,...  DOCUMENT THE ECM'S CURRENT STATE AND BACK 
IT UP!!!...

The FIRST thing to do is make a project folder for the engine/truck to do all your editing in. Under the 
C:\calterm III\BAC\ folder, make a new folder, naming it it after the truck make/model/year, and VIN-number, 
or some other similar scheme. From here on out, I will refer to this folder as your 'Project' folder. This project 
folder will be the place to store, and edit your engine Calibration, etc. This way you will have a single folder for
the truck to put all the info and files into. I use a folder name that has the truck make and model, etc. so that I 
can see what type of truck it was without having to open the files. It makes it easy to find similar truck, and 
their settings if you run into a bad delete or have other problems.

Make a FULL ECM Report...



Next, open Insite and connect to the truck 'THE KEY SWITCH IN THE TRUCK HAS TO BE ON, ANY 
TIME YOU ARE COMMUNICATING WITH THE ENGINE!!!!!'. If the ECM requires a password to connect, 
use the ZAPPIT feature of Insite to clear it out. It is only going to keep getting in your way. Browse through the
fault code history, and simply replace any sensor that is associated with any errors that are NOT EGR related. 
This helps to ensures there will be no bad sensor feedback to the ECM. Take care of any other NON-DPF issues
that might be plaguing the engine/truck at this time as well.

THE TRUCK MUST BE IN GOOD WORKING ORDER!!!. Next, perform a maintenance reset on the 
DPF, and then clear ALL faults, both Active and Inactive. Resetting the DPF and clearing its faults before the 
back-up is very important because, once the DPF has been deleted, the Insite software will NOT let you go into 
the After-treatment section to perform these tasks. This means if there were faults in there, like a DOC Face-
plug alarm, they will become permanent. After that, go to the 'Work Order' screen and start a new work order if 
it has not been done. Allow the ECM to be backed up via the work order. After the ECM is supposedly backed 
up, the next thing you should do is print out the ECM image. Expand the work order, highlighting the ECM 
image, and choose 'Print ECM Image(s). Print the entire image to a PDF file (TinyPDF is needed), and save it 
into your Project folder for the truck. It is NOT an actual ECM Image by any means, but rather all your settings 
for that particular truck. That 80+ page printed ECM image is very important!. It will contain your settings 
for all of the devices on the truck, like what address each of the switches are assigned to, etc. It is very difficult 
to get this information back if it gets corrupted or lost!

Unfortunately, the Insite software does NOT back up the entire ECM, though it says it does. Only Calterm 
will do a complete backup of the entire unit. Calterm, on the other hand, although it has some options for doing 
so, does NOT clear fault codes, or read features and settings very well, so Insite must be used first. 

 After you have your full ECM report, close Insite so that you can run Calterm instead. For the life of me, I 
don't know why they didn't include a full back/restore feature for an entire ECM in Insite. Personally, I would 
think it would have been a very important feature to ACTUALLY back up the entire ECM, but it in fact does 
not. The ECM back-up feature for Insite is pretty much useless for backing up/restoring an entire ECM image 
from a blank slate, and only backs up user information, settings, etc. and NOT the entire thing. To do a 
complete head-to-toe backup, you must use Calterm, so lets get started...



Backing the ECM up with Calterm. A FULL Backup...

Here is an Overview of the process that is detailed below...
** Ensure Keyswhich in truck is at 'ON' position, engine NOT running.
** Open Calterm, Select Open Module with the right ecfg file, and choose 'Automatic'.
** After it comes up, unlock the ECM via 'Change-lock' and choose 'Save' button.
** Choose 'Upload' and upload it to your project folder, adding the .cal extension to the filename.
** Close the module and disconnect from the the engine/truck.
** Make a copy of the '*.cal' file for editing.
** Save the project folder and '*.cal' file to a USB stick or some other safe backup device.

With the keyswhich for the vehicle still ON, and the engine NOT running, it is now possible to connect with
Calterm. This is done by opening Calterm, and canceling any action it wants to perform. The next thing is to 
choose 'File --> Open Module'. It then asks to 'Select Module' with a pop-up window. 'Eagle Red' is the code-
name for the CM871, so this must be chosen for it to work correctly. The correct configuration file then needs 
to be selected via the 'Browse…' button. Find the metafile (CM87X … *.ecfg) that was saved in the BAC\ecfg 
folder for your engine, then choose the 'Automatic' Button.

Calterm will attempt to open the ECM at this point, and it is not unusual to get some warnings and/or error 
messages related to DLA Firmware if you have a Nexiq adapter. It is also not unusual to get a warning message 



if your ECM has a different version of software than the ecfg file you have. If they are close, then it is not likely
a big deal, but if they are very different, then you are likely to have problems. The best thing to do is get the 
closest matching ecfg you can find to what you actually have.

The next step that I do is unlock the ECM BEFORE backing it up. This ensures that it stays unlocked 
during, and after all future backups/restores. If you don't do this, then you will get errors when restoring any 
backups or edits. To do this, first check the status-bar at the lower left hand corner of the screen. You will see a 
small padlock symbol that looks closed/locked. If it is in fact locked, It can be unlocked by choosing 
'Calibration->Request Changelock' from the main menu. After a couple of seconds delay, the small padlock 
icon should change to an open padlock. The ECM will NOT unlock if the engine is running!. 

Once this is done, Choose the 'Save' Button at the top of the program. If you forget to choose 'Save' then IT 
WILL NOT STAY UNLOCKED PROPERLY!, and can result in some problems later. After it is unlocked, it 
can be backed up properly. In the menu at the top under the 'Calibration' section, the option 'Upload' is for 
backing it up to your PC,... and the option 'Download' is for sending in a new cal to the ECM. It is just the 
opposite from what most people would expect. To back up the ECM, Choose 'Calibration->Upload', then select 
the correct ecfg file, and clicking the '…' button to choose where to save it. Save it to your project folder and be 
sure to add the extension .cal or .xcal to the end of the filename. It will create a '*.cal' file image of your ECM.

Proceed with the backup, it will take about 8 to 10 minutes. If you get ANY ERRORS during this process, 
then I HIGHLY recommend that you STOP WHAT YOU ARE DOING!!!. This is a very bad sign. It indicates 
that communications to/from the ECM are unstable and if you attempt to edit parameters, or later, 'Download' a 
Cal into the ECM, then it is likely to fail, potentially rendering the ECM useless!. If you are getting any kind of 
communications errors while you are already connected, then you should NOT proceed!. It is NOT worth the 
cost of a new ECM. Once the 'Upload' is complete, there will be a full copy of the entire ECM with all 7,700+ 
parameter in it, saved as the file. This process does NOT remove the file from the ECM,.. Your backup is only a
copy of it. The engine will still run the same. Sure, the ECM is now unlocked, but nothing has been changed or 
removed.

>DONT MAKE THE MOST COMMON MISTAKE!!!!<...
>DONT MAKE THE MOST COMMON MISTAKE!!!!<...
>DONT MAKE THE MOST COMMON MISTAKE!!!!<...

The absolute most common mistake people make during this process is not making a backup of the original 
file!!!,... Calterm does not care if it overwrites your nice pristine file!,... Take the time to go into your project 
folder and make a Copy of the upload at this point!,... Not only that,... but you should Absolutely use WinRar 
(or WinZip) to compress it, making a compressed copy too. This ensures the original does not get destroyed by 
accidentally selecting it. At this point, you should also copy the file and the project folder with all your data to a
memory stick or some other safe place, away from all the editing. Don't get ahead of yourself. Just do it. I 
cannot count how many people I have seen make this mistake, only to regret it later.

Disconnecting from the ECM...

You can now disconnect from the ECM. Leave it Unlocked!. To disconnect from the ECM, Choose 'File--
>Close'. After a few seconds, you will see the main screen disappear, and be back to a blank session again. Give
the DLA about 10 more seconds to actually disconnect after that. It has to finalize the session. Always do this, 
or you could have problems connecting back to it, especially after sending it a new file later on.



Running an Overlay...This is where the magic Happens!...

Now that you have the Cal file uploaded from the ECM to the PC, and you have backed it up somewhere, 
make yet another copy of it, only this time, re-name it. I like to name the file using the vin number combined 
with the words like '_MM_del_'  and todays date.cal'. The overlay process will overwrite this file, applying 
changes to it directly.  That is Why you need more than one backup of the original file. Calterm does not care if 
it destroys a file.

So,... you have your original file backed up, and have made a copy of it. You have re-named the copy of it, 
and are now ready to edit this new copy. The next thing to do is to run an “Overlay” on the file. Your probably 
asking yourself 'What is an Overlay?” and What does that do?,... 

Performing a MM Delete requires changing more than 200+ parameters in the Cal file. I suppose you could 
open the Cal file in Calterm and edit them one by one, all by hand, but I assure you that you don't want to do 
this. It is too easy to make mistakes or miss something, and not only that, it is very tedious. Calterm itself can 
do the editing for us if it has the right instructions on what to do. An 'Overlay' file tells Calterm what parameters
you would like to adjust, and what values to set them to. It will automatically adjust the contents of a Cal file, 
so that you don't have to do it manually. This prevents mistakes and ensures that almost all the changes 
necessary for a MM Delete are complete. The Overlay file does not change the entire Cal, but only those 
parameters specified. It does however directly change your Cal file, overwriting it, so that is why you needed to
make a copy first.

So,... where is this Overlay File?,...

I have done all the hard work for you,... I have included a copy of the overlay file(s) needed to perform a 
MM Delete for both bigger engines with the bigger Holset turbo's and for the smaller engines with the smaller 
turbo. Choose the CORRECT Overlay for your motor and copy it to your project folder. If you use the wrong 
one, you will get boost problems, so choose the proper file. BOTH the 650 HP files have the same torque and 
other settings, but have different maps based on what turbo you have. That is the only difference between them. 
One way to tell what turbo you have, is by what HP the motor was stock, according to the dataplate. If it is a 
525 HP  engine or higher, then it will have the bigger turbo, otherwise, it will most likely have the smaller one.

CAUTION!   CAUTION!   CAUTION!

DO NOT USE THE COMPETITION OVERLAY UNLESS YOUR WILLING TO SACRIFICE THE 
ENGINE!!!!! IT IS AN INSAINELY POWERFUL OVERLAY AND ALL VALUES ARE WELL 
BEYOND THE NORMAL CAPABILITIES OF A STOCK ENGINE!!! --- IT IS INDEED FOR 
COMPETITION USE ONLY!!!!! – YOU HAVE BEEN WARNED!!!

Running the Overlay...

Now that you have your overlay, and you have the Cal you uploaded from your truck,... you can do some 
magic on it. To run the overlay onto your Cal, Open Calterm if it was not already open, and proceed with the 
following steps...



** Choose 'Tools->Overlay'

** At the Select Product screen, Choose 'OK' (or choose Eagle Red if needed, then OK).

** If prompted to load previously selected files, always Choose 'NO'.

** Set Overlay mode to 'One-to-One' and choose 'Next >'.



** In the Select Overlay Options screen, choose the following... (most of these should already be set).
** “Use Scaled Values”
** Prefix: overlay
** Format: HTML
** “Ignore Range Limits”
** “Overwrite Existing Target Files” – (this one is important to set to prevent file corruption)



** Now Choose 'Next>'

** On the “Select Source Files” screen, do the following...
* Do NOT choose anything for Configuration. It must be blank.

* For the “Source:”, click the '…' button and go find your overlay file. Remember, the extracted overlay 
file is a ' *exp.xlm ' type file, so when the file browser window pops up, at the bottom, for
 “Files of Type” select ' Import/Export Files (*.ovl, *.exp.xml) '. Navigate to your overlay file,



 highlight it, and choose Open.

* Your overlay file should be listed next to “Source:”, but your not done on this screen yet. You must use 
the button labeled [ >> ] so that it will be listed in the spreadsheet looking area to the right. Once it is in there, 
you can choose 'Next>' at the bottom.

** For the “Select Target window”, do the following...
** For “Configuration”, use the [ … ] button to the right, and choose your '*.ecfg' file for your engine.
** For “Target”, use the [ … ] button to the right of it, then choose the copy of your engine cal file that 
you re-named earlier with 'MM_del' in the name.

** Once both files have been selected, choose the [ >> ] button to add them to the spreadsheet looking 



window to the right. Once they are in there, choose 'Next>'.

** At the “Select Parameters” screen do the following...
** In the left column, choose 'All Parameters' (little check-box). When you do so, all the parameters will 
jump to the right.
** Under “Filter Mode” be sure to choose 'Include Selected Parameters'. This is VERY important!. Nothing 

will happen unless you do this.
** Be sure the “Filter File Name” box is empty, and Choose 'Next>' at the bottom.



Your screen should look like this when your ready to select the “Next” button...

** On the summary screen at the bottom, choose 'Finish'.



It will perform its task, taking a few seconds, then a summary report will pop up in Internet explorer. The 
report will show the target and destination info, as well as some other things. The 'Paramaters Not Overlaid' 
window shows what parameters it skipped because they were already set correctly. This is normal and will vary 
from Cal to Cal. The 'Range Limit Info' just tells what parameters were set out of bounds. Some are set this way
on purpose actually, so it is normal to see a parameter or 2 listed there.

The 'Exceptions' section is very important if you happen to get exceptions. It shows what parameters could 
NOT be properly overlaid. It is full of jumbled text. To make sense of this text, first of all,... Ignore any areas 
that start with “OverlayReport Exception”. They are meaningless. On the other hand, sections that start with the
text “Exception occured while overlaying Parameter ???? ” (instead of ????, you will see a parameter name). 
The ???? will be the actual parameter that failed to get set.

(if you get exceptions),... So why did I get an exception?,... What does this mean?,...

Well, this means that your ecfg file didn't exactly match your Cal file. If it is just a couple of parameters like
'T_ISD_Enable ' and/or 'T_ISD_Tmptr_Enable', then there is nothing to worry about. It is simply the fact that 
your actual engine Cal does not have these settings. If it is a whole bunch more, like several dozen(s), then your
overlaid Cal is probably destroyed, and is likely useless. It is a good thing you took my advice and have a 
backup of your original Cal right?,... It also means that your ecfg file is just too different from your actual Cal 
file, and that you should NOT be trying to do a delete with it. Go get the right ecfg file that belongs to your 
engine!!!.

The 'Summary' section at the bottom shows the totals, nothing more. After looking at your summary page, 
you can close it out. Personally, I like to go into Calterms 'BAC' folder, get this overlay report file (labeled 
something like 'overlay_000_.ovr.html' or similar) and move in into the project folder with all the other the 
engine files for that particular motor. That way you have a record of what you did to the Cal file, and also it 
keeps the BAC folder from getting cluttered with junk. It is important to also do this if you ever want someone 
else to help you solve any issues. All the info and files are in one spot, easy to zip up and e-mail to someone if 
needed.



OK, I ran the Overlay... What the hell did it just do to my Cal file?,...

What it just did, was the MM delete to it. Your cal file should be ready to send back into your engine just 
like it is, if that was your only goal,... but you may want to customize and/or tweak it it first. Also, you have no 
reason to trust what just happened to your cal file. That overlay could have done anything it wanted to,...  you 
don't know what it did!... So If I were you, I would NOT trust it as is. I know, I wouldn't trust someone else's 
overlay without fully knowing what it did, so why should you trust mine?,... Refer to the main MM2 document 
if you want to know what the overlay does, and how to do a compare to see the actual changes.

Opening the file and Correcting the SOI,...

The Overlay can only replace settings blindly. It is not capable of anything else, so there a couple things that
you must do manually to get everything just right. After the overlay, most of the settings should be set correctly,
but there are 2 things that you need to adjust. One of them is the user SOI setting, and the other is a table that 
must be copied from one place to another.

To open your new file, Close out the overlay report if it is still open, then in Calterm, Choose File->Open 
Calibration. Then select your proper ecfg file and your new deleted cal file...

  When the main screen apears, Place your mouse on the first blank spreadsheet looking field, then choose 



“Editor” → ”Parameter Search”.

  Then, in the search box, type in “ C_CBL_SOI_Increment ”.  Then choose the search button.  Place a check 



in the checkbox next to the parameter C_CBL_SOI_Increment and choose “Apply”. The box should look 
something like this...

 Your not done yet with this window yet, so leave it open...

  Next, expand its view a bit, then you need to choose the two tables that you will need, in order to correct the 



engine's non-egr operating mode. The easiest way to do this is to search for “ C_CBR_SOI_ ”. Be sure to 
include the trailing underscore. If the search box adds text to the end as your typing, you can simply hit the 
delete key on your keyboard to delete the extra text before hitting the “Search” button. Here is a screen shot of 
the result, and the 2 tables you should put a check-box next to. 

  The 2 tables are “ C_CBR_SOI_Alpha1_Table “ and the “ C_CBR_SOI_Chi4_Table “...

  Choose the “Apply” button, and then the “Close” button.

    Your main screen should look like this now...



  For starters, Go back to the Screen0 tab, and adjust the SOI to the desired setting. Be sure to hit the Enter key 



on your keyboard, so that the parameter highlights in yellow. Here is a screen shot...

 

  You can set the SOI anywhere between '-0.7' and '8.0' … The factory default was zero, and is for EGR,... 8.0 is
for maximum fuel savings, and -0.7 is for maximum torque. Most smaller engines (below 525 HP hardware) do 
very well at a setting of 8.0 degrees, and the bigger trucks (525 HP and above hardware) do better at 4.5 
degrees. The only reason to go below 4.0 degrees would be for competition purposes, where you trade away 
fuel efficiency for extra power.  If you not sure, then just leave it at 8.0 if you have your engine STOCK, was 
BELOW 525 hp, and set it to 4.5 if you have an engine above 525-HP. Refer to the main MM2 document if you
want to know more.

  After you have it set where you want it, Choose the big “Save” button at the top of the program. This will 
make the change permanent.

Correcting the SOI tables,...



Next,... you need to fix the SOI table for the non-egr operating mode in the engine. Every engine, and its 
calibrations are different, so I do NOT recommend just simply setting this table the same for all motors, nor do 
I recommend you set your engine to the parameters shown in the screen shots. They are for showing you what 
to do only. It causes the engine to run inefficiently, and can actually damage the motor as well. Instead, you 
need to copy the correct mapping from the “ C_CBR_SOI_Alpha1_Table ” over to “ C_CBR_SOI_Chi4_Table 
” for whatever factory calibration your motor was designed for. To do this, choose the 
'C_CBR_SOI_Alpha1_Table' tab at the top, then click on any field within the data, and press 'CTRL-A', then 
'CTLR-C'. This will copy the entire table to the clipboard.

  Once you have the data in your clipboard, Select thew tab for the 'C_CBR_SOI_Chi4_Table' (this is the non-



egr operating mode SOI table), and choose, again, any field, then press 'CTLR-A', and 'CTRL-V' to paste the 
data from the other table into this one.

  Now, you have the correct SOI mapping for your motor in the right place for best power and efficiency. 
Choose the big “Save” button at the top once again.

  Now that your done with the editing, and have save your file, it is time to put the file into the ECM.



Sending the file back to the ECM,...

 This is the point of no return,... Sending the file to your ECM can be a nervous moment. If something fails, 
then it can potentially turn your ECM into a useless brick (paperweight). Do not say you weren't warned. If you
are getting communications errors, or lots of retries when you connect to the truck, or when you are reading 
parameters, etc., then I suggest you figure out how to get a better, more reliable connection to your ECM before
trying to send the cal via Calterm. Any hiccup during the download, and it could send the ECM into boot mode 
permanently, or worse, make it unable to communicate all together. That being stated,... here is how its done.

Choose 'File → Close' to close the calibration file out, and then exit Calterm completely, then wait about 10-15 
seconds. I have seen Calterm get flaky after editing files, then trying to download them, so clocing it 
completely is for good measure, and ensures Calterm has a fresh start.  The keyswitch in the truck should still 
be on from when you backed it up, if not, turn the truck back on without cranking it up. Open Calterm again, 
and when the program opens again, cancel any action it wants to perform, then choose 'File → Open Module' to
connect to the truck, just like stated above.

** After you are connected, you are at the main screen, and you have the Unlock symbol on the bottom left 
corner of the escreen, wait again about another 30 seconds or so for communications to stabilize, then choose 
'Calibration → Download'. This is the option to 'Send' the program from your PC to the ECM.

* Next, choose the correct ecfg file for your truck, then the newly made MM2 file you have edited, and ensure 
the check-boxes for backup/restore, parameters etc. are NOT checked.

* Choose the 'OK' button and wait for the download. It will take 10-12 minutes to complete.

* do NOT do ANYTHING to the truck while it is downloading. Just wait for it to finish. If anything happens 
during this download, it can damage the ECM.

  Do NOT get in a hurry when it completes. Wait a bit, and you will see that Calterm will re-start. After it does, 
wait another 10-15 seconds, then reach in and crank the truck. It should now run with the new cal, and the 
software side of the delete is complete.

Hardware Modifications,...

  

No contradiction to other people's methods here, just what I have 
experienced,...

It is recommended to ... 

** Ensure the IMAP and Exhaust BP Sensors are new, or are in very good condition. The engine will rely 
heavily on them afterwards for good efficiency.

** Block the gas flow at the point where the Venturi pipe meets the Intake Manifold (there are several ways to 



do this). This prevents excess stress on the EGR cooler due to constant vacuum/pressure conditions, and also 
prevents increased lag in the charge circuit/turbo. Blocking of the Exhaust flow between the EGR cooler and 
exhaust manifold can be done as an addition to this, but is usually unnecessary, unless the engine is to be 
programmed above 650 HP. Blocking at the Venturi is more important to prevent stress and lag, especially if the
EGR cooler is to remain intact.

My preferred method: A 6-inch long 3/8" bolt from high quality stainless with some 1-1/4" fender washers 
stacked up works just fine, and is the easiest, and most stealth solution of them all. BE SURE TO USE ALL 
STAINLESS!, heat and moisture build up in the pipe and can rust away anything of poor quality.

** It is not necessary, and I do NOT recommend removing the EGR cooler. The EGR Cooler itself can be 
removed, but ONLY if you weld fittings where the water used to flow and install a 3/4" WATER line across the 
water inlet/outlet circuit where it was removed. This prevents excess pressures on the water pump, and re-
establishes proper water flow to the back oil cooler inside the motor. The Water pump has a separate port for the
EGR cooler that it feeds, directly from the vanes of the pump. (this has been tested and confirmed)-- If you 
block the water circuit off, it will build up about 70-PSI of pressure in this blocked off circuit, putting excess 
stress on the water pump. You CANNOT block the water flow off!,... Again,... MOST of the 'Big-Boy' delete 
companies do this out of sheer ignorance!,.. Don't be ignorant!,.. leave the EGR cooler intact, or make a bypass 
circuit for it.

** remove 80% of the DPF, and about half the DOC. You can hollow out more of the DOC if you don't care 
about it making the exhaust louder. The more you open them up, the more efficient the engine becomes, but I 
like to leave about an inch or so around the outside of the DPF, and only take half the DOC. This prevents 
someone from 'Tapping' on them to see if they are hollow, helps keep the truck exhaust from becoming too 
loud, etc. It is possible to remove them and use a straight pipe/muffler instead, but it is nice to have it look 



stock.

** Remove the Delta-P sensor and break away the center pin in its electrical connector, then re-install it/plug it 
back in. EGR delete or not, the engine will still try to protect this sensor. Removing the center pin from it 
ensures it reads zero all the time. This prevents silent derates that have been seen on some trucks, if the sensor 
itself were to go bad. The feedback from this sensor needs to be zero at all times, regardless of what type of 
delete you have.

** Drill a 3/8" hole in the actual crank case filter itself, and NOT the cover. This allows the engine to breathe 
much better, and is needed if the power is to be turned up by very much, or if the engine has a lot of miles on it.

** Boost and PYRO gauges are needed to monitor exhaust temps to help protect the turbo, and to help the 
driver improve fuel economy. I heavily recommend installing them in the manner described in the main MM2 
document.

 Now you will be able to adjust the ECM programming to suit your Off-road needs if you like. Any custom 
tuning, fueling, turbo mapping, etc. is now possible to fine tune everything in. Be sure to check your maximum 
boost pressure under full torque load. It should be NO MORE than about 40 PSI. More boost does NOT mean 
more horsepower in these motors. About 36-38 PSI at max torque is the 'sweet spot' on these engines at 600 
horsepower. More boost than that is a waste and will cause problems.

  This overlay is conservative in regard to the turbo mapping, so over-spin should not be a problem, but check it
any ways just to be sure. Also check the RPM of the turbo under max load. They can spin 105k RPM max,... 
Any more, and it is over-spinning, and not good for it.

==================

So,... Summing this up,... At the VERY LEAST / Simplest to do,... No need to make more work than 
necessary....

* New IMAP and Exhaust Back pressure sensors (if they are old).



* 80% hollow out the 'DPF can, and ½ the 'DOC'. You can hollow out more of the DOC if you don't care about 
it making the exhaust louder.

* 6" HIGH QUALITY STAINLESS Bolt, washers, etc. inside the Venturi pipe.

* 3/8" Hole in crank case filter

* Center electrical pin of Delta-P removed/broken away.

* Installing Pyro and Boost Gauges.

* ECM Reprogramming.

* Leave all other systems intact.

====================

!!! REMEMBER: This Cannot be done in countries where it is illegal 
to tamper with these systems !!!

Good luck... and be safe! – ZeroCrisis


